IPB

Здравствуйте, гость ( Вход | Регистрация )

Фото
 
ALX .
ALX
Начинающий
39
Великий Новгород
Август-3-1980
Интересы
Нет данных
31-March 04
1045*
22nd December 2012 - 15:57
Dec 10 2019, 00:39
7 (0 сообщений в день)
AIM Нет данных
Yahoo Нет данных
ICQ 336062022
MSN Нет данных

ALX

Пользователи

*


Темы
Сообщения
Blogs
21 Dec 2012
Задача:

Есть конфигурация на основе некой типовой, например на основе УТ11
Нужно для ряда объектов реализовать возможность использовать типовые возможности УТ11 по ограничнию доступа либо включить свои.
То есть использовать в роли в запросе ограничения доступа либо один шаблон либо другой (либо разные параметры одного шаблона)

Вот такой пример запроса работает отлично:

ГДЕ
Выбор
Когда &CRM_ИспользоватьОграниченияCRM Тогда
Партнер.ДоступДляПодразделений.Подразделение = &CRM_ПодразделениеТекущегоПользователя
Иначе
Подразделение = &CRM_ПодразделениеТекущегоПользователя
Конец

А вот такой вариант не работает, выдает ошибки:

ГДЕ
Выбор
Когда &CRM_ИспользоватьОграниченияCRM Тогда
Партнер.ДоступДляПодразделений.Подразделение = &CRM_ПодразделениеТекущегоПользователя
Иначе
#ПоЗначениям( "Документ.CRM_СчетНаОплатуПокупателю","Чтение","","","Т.Партнер.ДоступДляПодразделений.Подразделение = &CRM_ПодразделениеТекущегоПользователя",
"","", "","", "","", "","", "","", "","", "","", "","", "","", "","", "","", "","", "","", "","", "","" )
Конец

При этом код с шаблоном сам по себе работает, ошибка только когда он вставлен в условие.
Ошибку выдает вся конструкция в целом, то есть как я понимаю при парсинге. А не в момент когда отрабатывает "Иначе"

Можно ли как то это реализовать или придется затирать типовые запросы УТ, которые все построены на использовании шаблонов БСП?


P.S.
Понятно что можно создать 2 набора "одинаковых" ролей с разными RLS, для них создать копии профилей доступа, группы доступа и т.п. и даже написать механизм который при смене настройки будет переносить пользователей из одного набора групп доступа в другие, меняя таким образом наборы ролей.
В этом есть даже плюсы - не нужно редактировать типовые роли.. Но тогда надо создавать кучу "копий" ролей и прочее
31 Jul 2005
подскажите как вывести на печать диарамму ганта.
1) что присваивать рисунку табличного документа? Всмысле, какой тип?
ТабличныйДокумент = Новый ТабличныйДокумент;

Можно так:
Рисунок = ТабличныйДокумент.Рисунки.Добавить(ТипРисункаТабличногоДокумента.ДиаграмаГанта);
Но как присвоить рисунку данного типа саму диаграмму?? свойство Объект недоступно для записи.

А можно так:
Рисунок = ТабличныйДокумент.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
КартинкаГант = Параметры.ДиаграммаГанта.ПолучитьКартинку();
Рисунок.Картинка = КартинкаГант;
Рисунок.РазмерКартинки = РазмерКартинки.РеальныйРазмер;
ОбластьРисунка = ТабличныйДокумент.Область("R1C1:R50C50");
Рисунок.Расположить(ОбластьРисунка);
ТабличныйДокумент.ОтображатьСетку = Ложь;
ТабличныйДокумент.ОтображатьЗаголовки = Ложь;
ТабличныйДокумент.Показать("Диаграмма Ганта",,Истина);

Но как задать нужную область, что вывести картинку целиком? ведь заранее не расчитать какой размер у диаграммы...
("R1C1:R50C50") -написано от балды, можно ли вывести картинку "поверх" ячеек, не вставляя ее в конкретную область?
31 Mar 2004
вот код модуля формы элемента справочника:
//======================================================
Процедура ОткрытьСтраницу()
ЗапуститьПриложение(ВебАдрес);
КонецПроцедуры

Процедура КнопкаОткрытьВебАдресНажатие(Элемент)
ОткрытьСтраницу();
КонецПроцедуры

Процедура ПриОткрытии()
ОткрытьСтраницу();
КонецПроцедуры
//======================================================
Почему приОткрытии() срабатывает и сайт грузится, а клик по кнопке
(КнопкаОткрытьВебАдресНажатие()) нет???

Процедура "ОткрытьСтраницу()" точно отрабатывает и по клику, и при открытии формы (проверял)....но при открытии формы страница открывается, а по клику на кнопке - нет sad.gif(
ALX .

ALX.

.
RSS Текстовая версия Сейчас: 10th December 2019 - 00:39